Log in interrupted
Incident Report for CrossEngage
Resolved
Our engineers did not see any irregularities and are now closing this topic.

Your CrossEngage Team
Posted Apr 24, 2024 - 21:16 CEST
Monitoring
A fix has been implemented and the login is working as expected. Our team will continue to closely monitor the platform.

Sincere apologies for the inconvenience and thank you for your understanding.
Your CrossEngage Team
Posted Apr 24, 2024 - 17:53 CEST
Investigating
It is currently not possible to login into our platform. Our engineers are currently working on rectifying this. We will publish an update as soon as logging in is possible again.

All other services are running normally.
Posted Apr 24, 2024 - 17:47 CEST
This incident affected: User Interface.