Data Processing Delay
Incident Report for CrossEngage
Resolved
After thoroughly monitoring our systems we are marking this incident as resolved.

Once more, we apologize if this caused any inconvenience. Feel free to get in touch with us if you have any questions.

Your CrossEngage Team
Posted May 02, 2024 - 12:45 CEST
Monitoring
After our data centre addressed network instabilities, our application recovered. Dispatching is now working as expected. We will keep monitoring the system in the upcoming hours.

Once more, please accept our apologies for the inconvenience this causes and do reach out if you have any further queries.

Your CrossEngage Team
Posted May 02, 2024 - 06:13 CEST
Identified
The cause has been identified and our data centre provider is in the final stage of implementing the solution.
Just a small reminder. All the dispatches are paused, the incoming data is being queued (no data has been lost) and will be processed as soon as the issue has been resolved.
We will keep you updated about the progress. Our apologies for the inconvenience this is causing. Feel free to get in touch if you have any questions.
Your CrossEngage Team
Posted May 01, 2024 - 23:35 CEST
Investigating
Our Datacenter provider informed us about degraded network performance.

They are working to find a solution as fast as possible.Some instabilities are expected in the next hours.
We have joined forces with our provider and keep monitoring the situation over the upcoming hours.

Apologies for any inconvenience this may have caused you. Let us know if we can be of any assistance.
Posted May 01, 2024 - 18:41 CEST
Monitoring
The issue has been identified and a fix has been implemented. We are rapidly consuming data queues & will keep monitoring in the coming hours.

Our apologies for the inconvenience this might have caused.
Posted May 01, 2024 - 15:19 CEST
Identified
We are currently experiencing degraded platform performance connected to segmentation.

In order to implement measures to solve it we have paused message dispatching.

Our engineers are currently working on this. We will publish an update as soon as campaign execution resumes.

Please accept our apologies for the inconvenience this causes and please do reach out if you have any further queries.
Posted May 01, 2024 - 12:32 CEST
This incident affected: Campaign Dispatch (Audience campaign dispatch, Realtime campaign dispatch, Stories Dispatch), APIs (API v1.0, API v2.0), and Segmentation, Web tracking.